Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Recherche Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

cURL/libcURL 7.x < 7.33.0 Host Name Validation Bypass

Medium

Synopsis

The host is running a version of cURL/libcurl that is vulnerable to a host name validation bypass attack vector.

Description

Versions of cURL/libcURL older than 7.33.0 are unpatched for a flaw that is due to a file retrieval tool that would disable the 'CURLOPT_SSLVERIFYHOST' check when the 'CURLOPT_SSL_VERIFYPEER' setting was disabled. This may allow a remote attacker to disable SSL certificate host name checks.

Solution

Upgrade cURL to version 7.33.0 or higher.